Elektroda.de
Elektroda.de
X
Elektroda.de

Mini-Oszilloskop DSO 138 - Montage, Test, Meinung

TechEkspert 61020 205
This content has been translated flag-pl » flag-de View the original version here.
  • Jawi_P
    Niveau 35  
    Nun, ich werde fragen, ob jemand schon nach einem Display für es gesucht hat?
    Ich habe es beschädigt, obwohl ich es selten benutze, es ist ein bisschen schade.
    Gruß
  • gumisie
    Niveau 43  
    Jawi_P hat geschrieben:
    Nun, ich werde fragen, ob jemand schon nach einem Display für es gesucht hat?
    Ich habe es beschädigt, obwohl ich es selten benutze, es ist ein bisschen schade.


    Nun, es passiert (es ist schade 13,50 PLN fürs Gehäuse). :wink:
    Link
  • Jawi_P
    Niveau 35  
    gumisie hat geschrieben:
    Nun, es passiert (es ist schade 13,50 PLN fürs Gehäuse).


    Jetzt bin ich auch so schlau ;) Aber vorsorglich wahrscheinlich immer noch nicht :)
  • lukaszd82
    Niveau 30  
    Ich gebe das Gehäuse ab, wenn ich ein neues, besseres drucke :>
    Ich habe für den Tester gedruckt, sehr grosser Unterschied :D
    Es ist seltsam, dass niemand ein Projekt für etwas Kühleres zur Verfügung gestellt hat, vielleicht sogar mit einem vorgesehenen Platz für Akku.
  • LA72
    Niveau 40  
    lukaszd82 hat geschrieben:
    Es ist seltsam, dass niemand ein Projekt für etwas Kühleres zur Verfügung gestellt hat, vielleicht sogar mit einem vorgesehenen Platz für Akku.


    Sie irren sich :D
    Link
  • ostrytomasz
    Niveau 23  
    Ich habe kürzlich den DSO138-Klon erhalten - ich habe ihn mit der Firmware DLO138 getestet und eine Bibliothek hinzugefügt, um die Wellenform/Wellenformen auf dem PC in der Miniscope Anwendung v4 anzuzeigen (Verbindung über UART) - http://tomeko.net/projects/dso138/.

    Wenn sich jemand entschied, die Firmware zu ändern, würde ich empfehlen, zuerst die originelle herunterzuladen - im Allgemeinen gab es zwei Versionen, die sich in der Empfindlichkeit des analogen Pfads unterschieden. Die Firmware muss nicht unbedingt die gleiche sein wie auf der JYE Tech-Website - in meine Exemplar gab es zum Beispiel eine Version ohne das Firmenlogo beim Start. STLink ist natürlich bequemer als über UART (Jumper).
  • japko1024
    Niveau 18  
    Weiß jemand, wo ich den richtigen Bootloader für DSO138 herunterladen kann? Ich muss den defekten Mikrocontroller in diesem Oszilloskop (STM32F103C8T6) ersetzen. Wo kann ich alternativ bereits vorprogrammierte kaufen (nur Bootloader oder komplette Firmware)?
  • ostrytomasz
    Niveau 23  
    japko1024 hat geschrieben:
    Weiß jemand, wo ich den richtigen Bootloader für DSO138 herunterladen kann?


    Der einzige Bootloader (UART) befindet sich im ROM, der zweite fehlt, nur die Anwendung.
    Aus meinem Stück kopiert: http://tomeko.net/projects/dso138/bin/original_firmware.bin
    Bei mir funktioniert auch https://github.com/dpavlin/DLO-138 und die Version von JYE Tech nicht.
  • japko1024
    Niveau 18  
    Reicht es aus, den neuen STM32F103C8T6 zu löten und dann, als würde ich die Firmware in einem funktionierenden DSO138 aktualisieren (JP1- und JP2-Jumper und Hochladen über UART-Pins mit einem normalen USB-UART-Konverter)?
  • ostrytomasz
    Niveau 23  
    Ich werde die Jumper-Nummern nicht bestätigen (dies sind Klone, die sich unterscheiden können), aber ja.
  • ay56
    Niveau 28  
    Firmware DSO 138. Original.
    Schema - Anweisung.
  • Krzychu23
    Niveau 16  
    Hallo

    Ich habe DSO138 zusammengestellt und habe zwei Probleme:
    1. Spannungen - Ich habe alles nach Anleitung gemessen, aber statt -8,11 und -8,08 V (gemessen an L1 bzw. TP25 (siehe Foto - linke Seite der Ergebnisse) habe ich -16,43 V und -16,01 V. Außerdem liegt das Testsignal weit über dem LCD, ich kann es erst sehen, nachdem ich auf das Maximum heruntergefahren bin (zweites Foto).
    Es ist auch unmöglich, diese Spitze am Anfang der Welle "abzuflachen" - was man auf dem Foto sehen kann, ist der Effekt des Drehens C4 auf das kleinste.

    Ich ging vor dem Löten durch alle Elemente und sie schienen in Ordnung zu sein.

    Können Sie vorschlagen, wo man nach dem Problem suchen kann?
    Mini-Oszilloskop DSO 138 - Montage, Test, Meinung Mini-Oszilloskop DSO 138 - Montage, Test, Meinung
  • HD-VIDEO
    Niveau 42  
    Sie haben eine zu hohe Versorgungsspannung am Stabilisatoreingang, die für 79L05 jedoch akzeptabel ist, überprüfen Sie die Widerstände R41 und R43.

    Sie messen den Test bei 0,5 V DC, führen Sie ihn bei AC durch.
  • Krzychu23
    Niveau 16  
    Danke für die schnelle Antwort. Ich habe erneut gemessen, diesmal mit AC. Die Spannungen unterschieden sich kaum, nur hatte ich statt -8,08 V nicht 16,01 sondern 16,41, und an V2 (unten im Bild) statt 1,66 V bekomme ich 1,84 V. Mir ist übrigens aufgefallen, dass ich diese drei Spannungen nicht gemessen habe (oben in der Abbildung, "zweite Zeile", aber auch sie sind unbedenklich (0,18 V, 6,38 V und 9,39 V gemessen, bzw. 0,19 V, 6,43 V und 9,39 V im Bild).

    SMD-Widerstand R41 gemessen ohne Auslöten von der Platine - ca. 9,33K, R42 9,56K. R43 ist auf der Platine nicht zu finden.
  • HD-VIDEO
    Niveau 42  
    Falsch, es soll R42 sein und nicht R43.
    Die Spannungen ändern sich nicht - Sie schneiden nur die DC-Komponente des Testsignals ab; Stellen Sie den CPL-Schalter auf AC.

    R41 / R42 10k / 1k SMD; auf den Bildern vom Handbuchs gibt es keinen R41.

    Krzychu23 hat geschrieben:
    R42 9,56 K

    Es sollte eine 1k sein, Markierung darauf ist 1001.
  • Krzychu23
    Niveau 16  
    Mein Messfehler - der tatsächlich gemessene R41 beträgt 9,33 k und R42 0,98 k. Markierungen auch ok - R41 1002, R42 - 1001.
  • raro
    Niveau 12  
    Ich möchte mein DSO138 kalibrieren. Wie sich nach Erhalt des Pakets herausstellte, ist es ein Klon/Fälschung!
    Ich habe die Schalter laut Anleitung eingestellt und die Sonde angeschlossen. Das Bild, das ich bekomme, wird auf dem beigefügten Scan dargestellt. Hier stimmt leider etwas nicht! Liegt es an meinem Setup-Fehler oder ist das Oszilloskop defekt?

    Mini-Oszilloskop DSO 138 - Montage, Test, Meinung
  • HD-VIDEO
    Niveau 42  
    Dies ist eine andere Version.
    Du hast die Basis bei 200 µS, ich denke, PWM ist eingeschaltet.
    Wo schließt du die Sonde an?
  • raro
    Niveau 12  
    Ich schließe die Sonde (rote Krokodilklemme) an den gelöteten Jumper J2 an, und die schwarze Krokodilklemme ist nicht angeschlossen (wie im Kalibrierungshandbuch beschrieben).
    200 µs = 0,2 ms eingestellt (wie im Handbuch).

    Mini-Oszilloskop DSO 138 - Montage, Test, Meinung
  • raro
    Niveau 12  
    Du hast mich wohl richtig auf die PWM aufmerksam gemacht, sie war auf 16.00 kHz eingestellt - ich habe es "runter gemacht" auf 1.00 kHz - tiefer geht's nicht. Liegt es daran, dass es einen Jumper gibt?

    Mini-Oszilloskop DSO 138 - Montage, Test, Meinung
  • raro
    Niveau 12  
    Ich meinte den J2-Jumper (Testgenerator). Wird es möglich sein, nach dem Entlöten die PWM auf Null zu senken, oder ist das egal? Sollte der Jumper nach der Kalibrierung des Oszilloskops entfernt werden, spielt es eine Rolle?
    Ist es möglich, Originalsoftware von JYE Tech Ltd. auf diesen (meinen) Klon hochzuladen?
  • raro
    Niveau 12  
    @ay56 - ich habe dieses Handbuch, aber danke für den Versuch zu helfen. Übrigens das Handbuch ist für das Originalprodukt und ich habe einen Klon (leider gibt es einige Änderungen).
  • raro
    Niveau 12  
    Ok - ich habe einen "Jumper" geschrieben, weil ich, wie in der Anleitung angegeben, ein Stück Draht an zwei Punkte auf der Platine gelötet habe (siehe Foto in meinem Beitrag oben).
    [F]